Guild Wars Forums - GW Guru
 
 

Go Back   Guild Wars Forums - GW Guru > The Inner Circle > Community Works

Notices

Reply
 
Thread Tools Display Modes
Old Jul 15, 2009, 03:28 AM // 03:28   #121
Guest
 
Join Date: Oct 2008
Advertisement

Disable Ads
Default

Quote:
Originally Posted by imkey View Post
The way the system is readied for another guild wars instance is the "kill mutex" button which calls a function that iterates through the nt process list looking at all active guild wars instances. For each instance it finds, it attempts to find/kill the mutex handle which would prevent more gw instances from opening.

Putting the mutex killing functionality in a timer would eat up unnecessary cpu cycles. That mutex does not just get created randomly by guild wars, it only happens during the initialization function when guild wars starts. One just needs to make sure to hit the button once after a new gw instance is created to be ready to launch another.

I would have liked better integration with Texmod but since that is a closed source product and I am not aware of it accepting command arguments, you are correct in assuming that it basically just launches it. It was mainly added as a convenience to the user.

On another note, check out HandleManager.cs. I spent the majority my coding time on that file. Partly due to the fact that it P/invokes into Nt kernel api functions which are not well documented by Microsoft. Had to look at several sources to get the required constants and applicable functions. It contains the core mutex killing code which makes this application possible. All the other code is really just utility and gui.
Wow, that's it? That's... Stupidly simple, lol. I mean, you look at other programs that do this (Matty's, GWx2), which modify the registry and such, and this is such an genius idea. I'm impressed.
I'm also impressed at the neat code, an art form I can't seem to master...
Killamus is offline   Reply With Quote
Old Jul 15, 2009, 03:37 AM // 03:37   #122
Furnace Stoker
 
MisterB's Avatar
 
Join Date: Oct 2005
Location: Planet Earth, Sol system, Milky Way galaxy
Guild: [ban]
Profession: W/
Default

Thanks for writing this program. This was very easy to setup and use.
MisterB is offline   Reply With Quote
Old Jul 15, 2009, 11:41 AM // 11:41   #123
Frost Gate Guardian
 
Join Date: Dec 2006
Guild: Green and Pink
Profession: Mo/
Post

Well.. it also does set the registry to the right path before launch. This is required since gw.exe uses the registry value to locate gw.dat and gw.exe.

If it is not set to the right value, gw would not be using the right data file for use/updates.

Quote:
Originally Posted by Killamus View Post
Wow, that's it? That's... Stupidly simple, lol. I mean, you look at other programs that do this (Matty's, GWx2), which modify the registry and such, and this is such an genius idea. I'm impressed.
I'm also impressed at the neat code, an art form I can't seem to master...
imkey is offline   Reply With Quote
Old Jul 18, 2009, 11:44 PM // 23:44   #124
rattus rattus
 
Snograt's Avatar
 
Join Date: Jan 2006
Location: London, UK GMT±0 ±1hr DST
Guild: [GURU]GW [wiki]GW2
Profession: R/
Default

Problem.

I've been using this since you released it with little to no problems, yet today it's just falling down with "Error launching: F:\Games\Guild Wars\Gw.exe!"

Nothing has changed that I know of - I've been using the generated shortcuts to launch it which have never failed until now.
__________________
Si non confectus, non reficiat
Snograt is offline   Reply With Quote
Old Jul 19, 2009, 01:54 AM // 01:54   #125
Frost Gate Guardian
 
Join Date: Dec 2006
Guild: Green and Pink
Profession: Mo/
Default

That is strange. I do not have access to my build machine at the moment to change some source in Form1.cs to send you a debug exe to get more info on the error.

Will have access tomorrow night.
imkey is offline   Reply With Quote
Old Jul 19, 2009, 11:06 AM // 11:06   #126
rattus rattus
 
Snograt's Avatar
 
Join Date: Jan 2006
Location: London, UK GMT±0 ±1hr DST
Guild: [GURU]GW [wiki]GW2
Profession: R/
Default

Don't worry, imkey - logged on this morning and everything was fine again.

Maybe a Windows update temporarily threw a spanner in the .net framework or something.
__________________
Si non confectus, non reficiat
Snograt is offline   Reply With Quote
Old Jul 20, 2009, 07:49 AM // 07:49   #127
Ascalonian Squire
 
Trollstyle's Avatar
 
Join Date: May 2007
Location: Hungary
Guild: Unga Bunga Clan [UNG]
Profession: W/
Default

Hi Could anyone help me, I cant log in with two accounts anymore. The first one works but the second one I run using the multi-launch is not able to connet (error058).
Trollstyle is offline   Reply With Quote
Old Jul 22, 2009, 10:19 PM // 22:19   #128
Frost Gate Guardian
 
Join Date: Dec 2006
Guild: Green and Pink
Profession: Mo/
Post

error 58 is a networking configuration/firewall issue.
Make sure that both copies are allowed to pass thru the firewall.

If you can connect on one but not the other, it is most likely a firewall issue. The firewall software may have exceptions setup to allow one of them to connect but no the other. Just add the other to exceptions list.

Quote:
Originally Posted by Trollstyle View Post
Hi Could anyone help me, I cant log in with two accounts anymore. The first one works but the second one I run using the multi-launch is not able to connet (error058).
imkey is offline   Reply With Quote
Old Jul 23, 2009, 03:16 AM // 03:16   #129
Guest
 
Join Date: Oct 2008
Default

Quote:
Originally Posted by Trollstyle View Post
Hi Could anyone help me, I cant log in with two accounts anymore. The first one works but the second one I run using the multi-launch is not able to connet (error058).
Or, even more likey, GW is having server problems. That's the error code when their servers crash/reset too, despite not being mentioned anywhere.
Killamus is offline   Reply With Quote
Old Jul 23, 2009, 04:24 AM // 04:24   #130
Ascalonian Squire
 
Join Date: Dec 2005
Location: Ascalon
Guild: SOUP
Profession: W/Mo
Default

Thanks for this; so glad it is open source too, I feel safe
spamslayer is offline   Reply With Quote
Old Jul 23, 2009, 06:10 PM // 18:10   #131
Krytan Explorer
 
Awex Mafyews's Avatar
 
Join Date: Mar 2008
Location: Cornwall
Profession: W/Mo
Default

Hey I'm probably missing something simple here but I've made 2 copies of guild wars (from my original one) tried to launch then with GWML and 2 loading boxes appear and then only one opens properly. No error screen for other box it just disappears. I've tried GWx2 before and I've seen on this thread something about replacing exe. file but do you have to replace the original versions exe file too? Also tried running in administrator to no joy. I have windows vista 32 bit as well. Any help on the matter would very welcome

Edit: Failed to mention, I tried GWx2 before finding this and that didn't work either so don't know whether that's related in any way

Last edited by Awex Mafyews; Jul 23, 2009 at 06:37 PM // 18:37..
Awex Mafyews is offline   Reply With Quote
Old Jul 23, 2009, 07:09 PM // 19:09   #132
Krytan Explorer
 
Awex Mafyews's Avatar
 
Join Date: Mar 2008
Location: Cornwall
Profession: W/Mo
Default

Ok seems the problem was the exe file, just reinstalled my copy off of the guild wars site, started up GWML and it worked straight away perfectly Thanks a lot for the program.
Awex Mafyews is offline   Reply With Quote
Old Jul 24, 2009, 05:47 PM // 17:47   #133
Wilds Pathfinder
 
Star Gazer's Avatar
 
Join Date: Nov 2005
Guild: Zerohour Enterprises [ZHE]
Profession: W/
Default

excellent program. Thank you!

4 accounts on CoF run......oh the bliss!

also got 3 accounts ran through EotN with my primary. excellent!
Star Gazer is offline   Reply With Quote
Old Jul 26, 2009, 06:07 AM // 06:07   #134
Krytan Explorer
 
Join Date: Aug 2007
Default

this thing is awesome, thank you for this.
coil is offline   Reply With Quote
Old Jul 26, 2009, 06:42 AM // 06:42   #135
Ascalonian Squire
 
Join Date: May 2007
Location: Australia
Profession: Rt/
Default

tried 4 or 5 times to install /run this but it doesnt appear to work. I extracted the files and installed it, but I get an error every time I try and launch and it shuts down.

oh yeah.. running on XP home..

Last edited by Nida; Jul 26, 2009 at 06:45 AM // 06:45..
Nida is offline   Reply With Quote
Old Jul 26, 2009, 06:45 AM // 06:45   #136
Guest
 
Join Date: Oct 2008
Default

Quote:
Originally Posted by Nida View Post
tried 4 or 5 times to install /run this but it doesnt appear to work. I extracted the files and installed it, but I get an error every time I try and launch and it shuts down.
Do you have the .net framework installed? That looks very similar to the error I get when trying to run my code at school (They're far too "Busy" *cough*lazy*cough* to install it properly)
Killamus is offline   Reply With Quote
Old Jul 26, 2009, 06:48 AM // 06:48   #137
Ascalonian Squire
 
Join Date: May 2007
Location: Australia
Profession: Rt/
Default

Quote:
Originally Posted by Killamus View Post
Do you have the .net framework installed? That looks very similar to the error I get when trying to run my code at school (They're far too "Busy" *cough*lazy*cough* to install it properly)
um.. fresh computer install, had to format a few days ago, but I think I do... how would I check/know?
Nida is offline   Reply With Quote
Old Jul 26, 2009, 08:09 AM // 08:09   #138
Guest
 
Join Date: Oct 2008
Default

Control Panel -> Add/Remove programs, and look about 1/3rd of the way down. You should see "Microsoft .NET Framework X.X", if you don't, you don't have it installed. If you do have it, post the highest number you see there. You'll see a few, probably.
Killamus is offline   Reply With Quote
Old Jul 28, 2009, 12:32 PM // 12:32   #139
Jungle Guide
 
stretchs's Avatar
 
Join Date: Sep 2007
Guild: Untimely Demise [Err了] - SOHK
Default

Just installed this on one of my pc's so I can GM for my new pre character, worked like a champ with no issues in Vista.

Thanks for the great software.
stretchs is offline   Reply With Quote
Old Jul 31, 2009, 08:58 AM // 08:58   #140
Ascalonian Squire
 
Join Date: Jul 2007
Default

Is this Legal to use ?

Thinking of Anet's Emula



Think it's a awesome program and have so many possibilities all rdy know several things I can use this for
firefox74 is offline   Reply With Quote
Reply

Share This Forum!  
 
 
           

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
LF multi gameing guild :) king ram Looking For Guild 0 Jun 01, 2008 08:32 PM // 20:32
Hand of Ruin The Riverside Inn 63 Jul 15, 2006 01:10 AM // 01:10


All times are GMT. The time now is 01:03 PM // 13:03.


Powered by: vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
jQuery(document).ready(checkAds()); function checkAds(){if (document.getElementById('adsense')!=undefined){document.write("_gaq.push(['_trackEvent', 'Adblock', 'Unblocked', 'false',,true]);");}else{document.write("