Guild Wars Forums - GW Guru
 
 

Go Back   Guild Wars Forums - GW Guru > Forest of True Sight > Technician's Corner

Notices

Reply
 
Thread Tools Display Modes
Old Aug 24, 2011, 08:19 PM // 20:19   #1
Sivri
Pre-Searing Cadet
 
Join Date: Aug 2011
Advertisement

Disable Ads
Default Very slow patch download speed

Hello there.
Sorry if this has been posted about before, but I've been trying to find an answer for a while now and it seems to be a complete jungle >.<

Thing is, after four years of not playing, I decided to pick up the game again. So I just logged in after installing GW and GW:Factions. I don't have the newest one.
Anyways, as expected I am met with a patch download but.. It's downloading with 4-30 ish kb/s. I have an 8mb/512kb line (connected with cable) so it should go much faster.. At least so I would expect.
I've disabled my firewalls and checked that the client has permission to access the internet and such.
Any suggestions on what I could do to improve it, or did I just strike a time where everything is overloaded?

Thanks for the help
Sivri is offline   Reply With Quote
Old Aug 25, 2011, 02:07 AM // 02:07   #2
Bladed Tribble
Academy Page
 
Bladed Tribble's Avatar
 
Join Date: Jul 2009
Guild: Lunatics Running the Asylum [CRZY]
Profession: E/
Default

I'd bet you probably just hit the servers at a bad time. I'm on a ~11mb line and I've sometimes hit those speeds when having no other network usage, yet other times I can break 500+kB/sec. Just try at a different time and make sure you don't have stuff like Windows Updates being downloaded in the background, cause that tends to take up quite a bit of bandwidth (or so it seems)
Bladed Tribble is offline   Reply With Quote
Old Aug 25, 2011, 01:04 PM // 13:04   #3
Painbringer
Furnace Stoker
 
Painbringer's Avatar
 
Join Date: Jun 2006
Location: Minnesota
Guild: Black Widows of Death
Profession: W/Mo
Default

You are at there mercy when it comes to what speed they give you. But what you stated are really low…to be honest I only have seen that speed with Charter (I live in a rural location and there cable speeds matched the old telegraph speeds from the old west days…at least in my town) I have hence changed providers. I would do a speed test to ensure you do not have a network problem on your end. http://www.speedtest.net/ there is a couple other ones too you could use.

If you notice slow everything check all connections from your computer to outside your home. (See if it helps) If all cables look good and reconnected. Disconnect router so you have one for a straight connection from modem to computer. Then check speeds again. Use someone else’s laptop if you can find one and check speeds on your connection. (Virus scan your system if the laptop has no issues) Wait a day and check again with your system. Last resort you will have to call the provider and check for area outage, home visit etc…

Last edited by Painbringer; Aug 25, 2011 at 01:06 PM // 13:06..
Painbringer is offline   Reply With Quote
Old Aug 31, 2011, 08:01 AM // 08:01   #4
Meta-Stick
Pre-Searing Cadet
 
Join Date: Aug 2011
Guild: Wai
Profession: R/Mo
Default

I just had to make an account to comment on this. I am having the same issues as well since the last update.

1.) Reinstalling didn't work. Which now I'm also screwed because It would take a week to download everything at 30kbs.(I clearly notice my dl speed trying to shoot upward, but it ALWAYS hits 30kbs.)
2.) My firewall is fine with Guild Wars, I even disabled for a few minutes and started the game it to see if it could of been somehow messing it up.
3.) My connection is fine, because I've tested running 2Mbs on any other download.
4.) I've checked for malware, but couldn't find anything, and I keep a clean computer, considering I've been on the net for 10 years now I rarely pick anything up.
5.) I unplugged, and replugged back in all cords to my modem, wall, and computer twice. The second time, overnight, because letting it set for 30 minutes didn't work.
6.) I've also checked to see if anything else was eating up bandwidth, etc. , but nothing was.

So I came to the conclusion that whatever that last update was, caused the download speed to be throttled in some way. Which if this is true, it's unfortunate because I just reinstalled Guild Wars a week ago, so I don't have a lot of the areas downloaded otherwise this really wouldn't affect me. I really hope I'm wrong, and it's just a big coincidence. I really regret reinstalling because the game doesn't lag, it's just the slow downloads.

So I have a question for you Sivri, what ISP do you have? Maybe we can narrow it down to GW, or a ISP if what I think is true. :X
Meta-Stick is offline   Reply With Quote
Old Sep 09, 2011, 10:25 PM // 22:25   #5
Xsiriss
Jungle Guide
 
Xsiriss's Avatar
 
Join Date: May 2008
Default

Yeah I'm getting something similar, trying to get gw running on my new laptop. One thing that helps is:

.Create a short cut to your desktop directly from the GW application in its installed location

.Go to properties and after the target location put a space then -image

.Rename the shortcut Guild Wars -imagea faster rate.

This decompresses all patches and download them as one and apparently at faster rate. That said it still changes erratically from 30 to up to 300 kb/s for me.

Last edited by Xsiriss; Sep 09, 2011 at 10:30 PM // 22:30..
Xsiriss is offline   Reply With Quote
Old Sep 16, 2011, 11:51 PM // 23:51   #6
Goldwing
Pre-Searing Cadet
 
Goldwing's Avatar
 
Join Date: Oct 2007
Profession: Me/Mo
Default

Having the same issues with mine, and my wife's, downloads. We've tried the -image, and it hasn't improved. We're hitting 10-30 Kb/s on a 24+ Mb/s download connection (just re-tested to make sure). My wife has been patching since 7:30 EDT and is only at 45%. Personally, I'm ready to give up. I've downloaded/patched many games over the years and have never had any of them take this long.
Goldwing is offline   Reply With Quote
Old Sep 17, 2011, 01:00 AM // 01:00   #7
code
Academy Page
 
Join Date: Feb 2010
Default

Guild Wars downloads files in chunks of 16KB at a time, causing a full roundtrip of delay after every chunk because the server expects an acknowledgement.

It could be worth trying to check your ping (post traceroutes) against all of the File<n>.ArenaNetworks.com servers for n in [1; 12].

If you are in Europe, try running the following commands in an Administrator shell:

Code:
echo. && echo 206.127.146.41 File1.ArenaNetworks.com File2.ArenaNetworks.com File3.ArenaNetworks.com File4.ArenaNetworks.com File5.ArenaNetworks.com File6.ArenaNetworks.com File7.ArenaNetworks.com File8.ArenaNetworks.com File9.ArenaNetworks.com File10.ArenaNetworks.com  File11.ArenaNetworks.com File12.ArenaNetworks.com >> %SYSTEMROOT%\system32\drivers\etc\hosts
Code:
ipconfig /flushdns
Then restart Guild Wars and see if your download speed changed.
code is offline   Reply With Quote
Old Sep 17, 2011, 04:06 AM // 04:06   #8
architekt
Pre-Searing Cadet
 
Join Date: Sep 2011
Default

I just came back after a several years hiatus and man, is this thing downloading sloooooooooooow! I'm getting around 20-30kbps, like the OP. I have a 100mbps connection. If I turn on Steam, I can download a game at 11.5megaBYTES per second. Yet GW is going at the speed of a glacier. While running GW, I did a speedtest and it confirms that my connection is good:



Does GW use any kind of ports that I need to poke a hole in my hardware firewall for? Also, yes, I did the -image suggestion, no speed difference.

Last edited by architekt; Sep 17, 2011 at 04:19 AM // 04:19.. Reason: used [img] tag
architekt is offline   Reply With Quote
Old Sep 17, 2011, 12:20 PM // 12:20   #9
Goldwing
Pre-Searing Cadet
 
Goldwing's Avatar
 
Join Date: Oct 2007
Profession: Me/Mo
Default

Seems to have sorted itself out. Maybe their traffic was too high last night. Still not a great download speed (around 600 Kb/s average), but it's tolerable.
Goldwing is offline   Reply With Quote
Old Nov 25, 2011, 08:15 AM // 08:15   #10
simplex
Pre-Searing Cadet
 
Join Date: Nov 2011
Default

Going to necro this thread since I'm getting the same problem. Wanting to come back to the game and spend a bit of time playing, -image doesnt help speed things up, and i think the screencap pretty much sums it up.



Was downloading at 30KB/s at first, it sat on 50 for while, and now it's floating between 70-100..... which is terribly slow. Also, it's slightly frustrating. Anything i can do on my end to speed it up?

Seperate but related question; if i close the client downloader and reopen it later, does it restart, or resume from where it was up to.
simplex is offline   Reply With Quote
Old Nov 25, 2011, 03:22 PM // 15:22   #11
Quaker
Hell's Protector
 
Quaker's Avatar
 
Join Date: Aug 2005
Location: Canada
Guild: Brothers Disgruntled
Default

Quote:
Originally Posted by simplex View Post
-image doesn't help speed things up,
You're right of course, -image doesn't speed things up - but what it does do is to download the entire, updated game while you sleep or work or go to school.
If you start it going while you are AFK/asleep, it will seem to take no time at all.
Quaker is offline   Reply With Quote
Reply

Share This Forum!  
 
 
           

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:22 AM // 03:22.


Powered by: vBulletin
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.